O seu servidor funciona com a versão 4.4.9 do PHP, mas o WordPress 3.8.1 necessita pelo menos da versão 5.2.4.